Problème #1 – friendsofsymfony/user-bundle dev-master requires php

Problème :

Comment résoudre le :

friendsofsymfony/user-bundle dev-master requires php ^5.5.9 || ^7.0 -> your PHP version (7.0.15) overridden by "config.platform.php" version (5.3.9) does not satisfy that requirement.

J’ai rencontré ce problème lors de l’installation du célèbre bundle FOSUserBundle.

Context :

La version dev-master du bundle FOSUserBundle avait besoin de la version ^5.5.9 ou ^7.0 de php pour fonctionner. J’ai donc décidé d’installer la version 7 de php. L’installation s’est faite sans problème.

Tuto #1 : Comment installer PHP7 ou plus sur Mac OS

Une fois PHP7 installer, le problème n’était toujours pas résolu.

Solution :

Il faut vous rendre dans votre fichier composer.json et effacer tout le bloc platform :

Avant :


"config": {
    "bin-dir": "bin",
        "platform": {
            "php": "5.3.9"
    },
    "sort-packages": true
}

Après :


"config": {
    "bin-dir": "bin",
    "sort-packages": true
}

Et voilà, normalement votre problème est résolu.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *